One-click QT Installer for i8910 Users!!

Hi guys to make the whole Qt insatllation process much easier, me and madhacker have created a very nice one-click Qt installer!! πŸ™‚

Take a look at the video, and download it to enjoy the Qt software which have been released so far! ^_^

DOWNLOAD LINK : i8910 Qt INSTALLER

EDIT: to those who still have not understood what Qt libreries are… (sorry for being too technical in terms… ^^)

QT LIBRARIES ARE THE FILES THAT YOU NEED TO RUN APPLICATIONS WRITTEN IN QT πŸ™‚

THIS MEANS MY PACKAGE WILL NOT INSTALL ANY APPLICATON, IT WILL ONLY INSTALL THE FILES NEEDED TO RUN APPLICATIONS WRITTEN IN QT SINCE THE FUTURE APPLICATIONS WILL BE WRITTEN IN QT πŸ™‚

If you still have any question , write in comments πŸ˜‰

43 thoughts on “One-click QT Installer for i8910 Users!!

  1. Hey faenil – I was waiting for this!
    I am honest and gave HX-V7 a chance for the last week and I had to admit that it is not for me because of the following reasons:
    – not responsive
    – no voice recorder pause
    – voice recorded not found in soundclips
    – photo codec not really good
    – no sync after pausing a video

    This evening I will switch to n2o3.
    Glad that you have finished this QT-thing.
    One question: in the video you install wikitude_i8910.sis which comes with the QT from Wolfgang.
    Won’t this tell that QT and pips is already installed or do you have a special version?
    It is good to have you and your superb quality back – and also thanks to madhacker!
    Another question: Have your QT the audio libraries?
    Greetings Psy

    special version πŸ˜‰ I’ll publish it tomorrow with a video πŸ˜‰
    qt audio is still not completely implemented…nokia is still working on it

  2. I can also extract that Wikitude with SisEditor – will that be enough?
    (Still waiting until my accu is full – will have a really fast rom – you know I was on LITv2 before)
    Greetings Psy

    extract it, modify the pkg deleting “@ …” string, and repack it with makesis πŸ˜‰
    or wait tomorrow πŸ™‚

  3. dude u give a sis file of qt two weeks before… do i hav to install that .sis and now this which hav given…
    i mean to say both should i install… or i just install this…

    what do you mean dude? I gave nothing two weeks ago…

  4. Hi faenil.
    Sorry to be thick but. . . . what exactly is this giving/doing for us?
    Does it just sit in the background when installing QT sis files? It’s not a stand alone app is it? And where do we find there QT files?
    I’m sure, if you’re behind it, that it’s brilliant but in non tech terms please clarify.
    Many thanks.

    read EDIT section of the post πŸ˜‰

  5. Hiya mate. I reckon ‘gpsp4symbian’ is working smoothly now???
    Cheers. πŸ˜‰

    yes it is πŸ™‚ I offered my little help to summeli and we managed to get it working almost ok πŸ™‚

  6. Well I’ve installed your app and then Wikitude but nothing happens when clicking on the app! Do we need something on in Rompatcher?

    you don’t need anything… πŸ™

  7. Faenil, this achievement is just amazing….
    I might sometime write some app for our phone now when it runs Qt :). Once I checked some code for plain Symbian Carbide C++ and it was disguisting. Now with Qt everything is different! It’s the best tool for application development. Microsoft’s .NET can go hide in the bushes!!! Qt might save the Symbian!

    I’m glad someone understands the relevance of this news! πŸ™‚

  8. “Well I’ve installed your app and then Wikitude but nothing happens when clicking on the app! Do we need something on in Rompatcher?”

    same thing happens here.

    it’s very strange, check that you have Qt into Installed Application πŸ˜‰

  9. How can I find Qt softwares?
    Does Qt have some surprising feathers to us?
    Many THX~

    There are only some applications written in Qt at the moment (ComingSoon, WordPress for Symbian, Gpsp4Symbian, Wikitude)
    but all future applications for symbian will be written in Qt πŸ™‚

  10. awsome work faenil and welcome to madhacker! u guys make us so proud.. i8910 survives because of guys like you.. despite the different samsung API, u’ve been able to load all the Qt libraries.. cant praise u enough.. thank you both!
    and i’m still having some problems with my card and registration at paypal.. really want to donate some..

    np man πŸ˜‰

  11. Ciao, innanzitutto ti faccio i miei complimenti.

    Non riesco a installare il sis perchΓ© mi dice “Errore nel certificato”. Sapresti aiutarmi?

    hai bisogno dell’hack

  12. Thanks… faenil it worked great open horizons of the future ahead of us and I have another piece of news which…now can Porting all Apps from iPhone and Android to Qt…amazing

    yes if developers believe in Symbian…

  13. Hi faenil,

    first: amazing work!
    I uninstalled my previous wikitude version and installed your package to test those few qt-apps around here.
    Two files cought my attention: qTracker and betalabsclient.
    Bot somehow they make my baby restart or just show something like kkkkkkkkkkkkkkkkkkkkkkk instead of readable text.
    Those files are available at the i*mart-forum in the QT-thread.
    Can you look into them and tell me if it’s working on yuor i8910?
    If not, we have our first bug to fix πŸ˜€

    this is very strange…read the latest post, unistall QT and Wikitude, and then reinstall Qt using the One-click installer, and wikitude using my package (updated 25/07)

    Cheers!

  14. Thanks faenil, your comeback made us happy! since you were not in picture so i switched to HX but now i can i m back to FAENIL PIT…and great news about QT….go ahead and keep it up mate…good luck

  15. Anche a me errore certificato. Devo hackare i cellulare?
    Comunque grazie mille per averci dato QT, Γ¨ un grandissimo passo in avanti in ottica futura.

    sΓ¬ serve l’hack πŸ˜‰

  16. Lollvs, se hai una ROM originale devi hackare, poi da rompatcher attivare “Install Server RP+”. Se invece hai una ROM modificata, fai solo il secondo passaggio. Alla fine ci sono riuscito! πŸ˜‰

  17. Very nice!! if this is perfected in our I8910. it will be the best, and will definitely be a must have.. my only question would be, if ever we want to uninstall it. how can we do it easily? there are alot of libraries..

    read latest post

  18. hey sorry dude.. i by mistake wrote 2 weeks.. actually i was talking abt the package which u gave abt 2 days back..

    ok, install the latest One-click installer to have QT

  19. Pingback: Le librerie Qt di Nokia portate sui Samsung Omnia HD e altri Symbian | bruno trani dot info
  20. Pingback: » Le librerie Qt di Nokia portate sui Samsung Omnia HD e altri Symbian
  21. hi there, sorr for the dumb question but i landed here by another page and it sayd there this work on all symbain phones, I have a Vivaz Pro, does it work there too ?

    Yes I haven’t tested them on Vivaz but it should work perfectly πŸ˜‰ let me know πŸ˜‰
    Do notice that it’s not compatible with FontRouter (and maybe Ndrive)

  22. I am sure i am the thickest person here.

    I installed Wikitude from the official website, but it just hangs on launch and constantly drops the connection.

    I have been trying to install different flavors of QT and the pytho shell, but everything gives me certificate errors.

    Is it because i am still running the genuine Symbian that came with the phone?

    JY

    yes, you need the hack…

  23. Dear faenil,
    I have installed your Qt in my i8910. But after that i couldn’t go to APPLICATION MANAGER in my phone.. So its very harmful to me.. I can’t remove any softwares or even themes when i needed to remove.. So please give me a Solution. Otherwise your Qt is perfect..

    maybe you had c2z enabled…

  24. Installed one click QT from Faenil and Madhacker, installed stripped down Wikitude version posted by Faenil, disabled FontRouter and RP+ patches (open4all to be precise, I don’t have other patches in auto) and QT and apps work flawless.

    wonderful bro πŸ™‚

  25. HI,

    First off, What you guys do for the I8910 is GREAT! And thank you for that from another user.
    Tried installing the QT installer from above, but encountered an error: Certificate error, please contact application supplier.

    Any idea / thoughts why i got this?

    And do i need a custom ROM device?

    Looking forward to your response. And thank you again.

    Cheers,

  26. Hi. When I download and run your installer, should I see programs appear in my installed files list? I notice I have a couple there, such as OpenC libraries and PIPS, but I don’t see anything about QT there. I’m trying to use the Orange Wednesday app from Ovi Store which requires QT but it isn’t working. My phone is a SE Satio and it is hacked with RomPatcher running. Thanks.

  27. 😳

    Hi faenil,

    congratulation for passing your exams. After my vaccations i actually installed your manipulated qt-installer and wikitude…. But as in an earlier installation i got an networksession error. Does it depend on my provider FONIC or do i have to vary some adjustments ?

    Any idea ?

    CAMPAI Rhonin

  28. helo faenil.

    do you need a hacked phone to be able to use one click qt installer?
    i am using vivaz and currently it wasnt being able to install the libraries included in it.

    thank you

  29. β€œWell I’ve installed your app and then Wikitude but nothing happens when clicking on the app! Do we need something on in Rompatcher?”

    same thing happens here.

    it’s very strange, check that

    —————————————————————————————————-

    —–You must uninstall all Qt files… i think that are 3 if you installed normaly using Qt 4.6.2.
    It’s Qt, Qt WebKit and Qt Installer (i think).

    Just uninstall all Qt that Appears on your installed program list.

    Then it’s better to REBOOT your phone (don’t know why but here only worked after i rebooted… i tryed to install without rebook and get error).

    Onde hint is to disable the Rompatcher+ (c2z and install server) before installing wikitude.

    Then after reboot and disable rompatcher install wikitude for i8910

    —-It should work

  30. hi dud!!!
    please excuse me for my english i am leave in corsica πŸ˜‰
    ok….i instal qt installer in my i8910 but when i install gpsp i see a message in my fone”qt componement missing” i dont understand why please someone can help me???i need help far that thks

    something went wrong during the installation then … I can’t help you from here…

Leave a Reply